Anlık Bildirim

Apple, iOS ve macOS'ta TLS'nin eski sürümleri için desteği sonlandıracak

Apple, iOS 15, macOS 12 ve diğer işletim sistemlerinde TLS 1.0 ve 1.1'i kullanımdan kaldırarak, TLS'nin yeni sürümleriyle değiştirdi.
Oy Ver

Apple, iOS ve macOS'ta TLS'nin eski sürümlerini sonlandırıyor Tam Boyutta Gör

En son iOS 15, iPadOS 15, watchOS 8, macOS 12 ve tvOS 15 işletim sistemlerinin piyasaya sürülmesiyle Apple, Taşıma Katmanı Güvenliği (TLS) 1.0 ve 1.1'i kullanımdan kaldırdı. Şimdi teknoloji devi, gelecekteki tüm sürümlerde güvenli olmayan protokol desteğini kaldırmayı planlıyor.

TLS'nin "istemci-sunucu" modeline göre internet üzerinden bilgi alışverişi yaparken kullanıcıları casusluktan ve gizlice dinlemeden koruyor. Protokolün 1.0 ve halefi 1.1 sürümleri neredeyse 20 yıldır kullanılmakta. Ancak zaman değişiyor ve bu nedenle Mart 2018'de İnternet Mühendisliği Görev Gücü (IETF), dört yıllık tartışma ve protokolün yeni sürümü için yayınlanan 28 taslaktan sonra TLS 1.3'ü onayladı.

Apple, iOS ve macOS'ta TLS'nin eski sürümlerini sonlandırıyor Tam Boyutta Gör

Apple kullanıcı güvenliğini göz ardı etmedi

Kullanıcı güvenliği konusundaki endişesini her zaman vurgulamaya çalışan Apple, TLS'nin eski sürümlerinin terk edilmesini göz ardı edemezdi. Bu nedenle şirket aşağıdaki açıklamayı yayınladı:

"Platformları modernize etmek, güvenlik ve gizliliği artırmak amacıyla IETF, TLS 1.0 ve 1.1'den tamamen uzaklaştı. Bu protokol sürümleri ayrıca iOS 15, iPadOS 15, macOS 12, watchOS 8 ve tvOS 15'te kullanımdan kaldırılmıştır. TLS 1.0 ve 1.1 desteği gelecekteki sürümlerde benzer şekilde kaldırılacaktır."

Şirket, geliştiricilerin artık protokolün daha güvenli bir sürümü olan TLS 1.3'e kademeli bir geçiş yapmayı düşünmelerini tavsiye ediyor.

Bu haberi, mobil uygulamamızı kullanarak indirip,
istediğiniz zaman (çevrim dışı bile) okuyabilirsiniz:
DH Android Uygulamasını İndir DH iOS Uygulamasını İndir
Sorgu:
Yeni Haber
şimdi
Geri Bildirim